IPV6

Z Czela.net
Přejít na: navigace, hledání

Obsah

IPV6 úvod

IPv6 (internetový protokol verze 6) je v informatice označení nastupujícího protokolu pro komunikaci v současném Internetu (resp. v počítačových sítích, které Internet vytvářejí). IPv6 nahrazuje dosluhující protokol IPv4. Přináší zejména masivní rozšíření adresního prostoru (tj. možnost přidělit všem zařízením jejich vlastní IPv6 adresu) a zdokonalení schopnosti přenášet vysokorychlostně data.

Proč v czela.net - musíme tam všichni

-)

Potřebujeme IPV6 v czela.net

Zatím ne, máme vybudovanou infrastrukturu na IPV4

Plán

Plán je provozovat současně IPV4 i IPV6, pro IPV6 použít RB1200-AH2. IPV4 zůstane zatím na hrompacovi v sitelu.

Výhody

Žádný NAT všichni mají veřejnou IPV6 adresu

Co je hotovo

  • Máme přidělěn IPV6 prefix pro czelanet 2a01:490:1b:/48
  • Máme rozchozen IPV6 BGP router na RB1100-AHx2 na vlaně 4001 v kotelně Na stráni
  • OSPF IPV6 používá jiný routovací OSPF daemon, u Mikrotiku OPFV3 , ten je otestován
  • Používáme IP adresy automaticky generované z MAC EUI64
  • Máme rozchozeno IPV6 na páteři
  • Máme rozchozeno IPV6 na sítích viz tabulka dole

Naše adresové schema

  • Adresové schema koresponduje se stávající IPV4
  • Pužíváme automaticky generované IPV6 adresy EUI64, adresa se generuje z prefixu, který pošle router a MAC
  • Naše IPV6 adresa je
    • prvních 6 bytů je síť přidělěná pro czela.net (2a01:490:1b:)
    • byty 7 a 8 IPV6 adresy jsou 2 poslední byty z IPV4 sítě
    • těchto prvních 8 bytů tvoří prefix sítě
    • zbytek 8 bytů je automaticky generovaný
    • síťová maska maska je 64 (EUI64 jinak to nejde)
  • Příklad 1
    • IPV4 adresa routeru 10.93.58.1/24 tj. sít 10.93.58.0 , dva poslední byty sítě "58 00" = hex(3a00) by byla schematicky IPV6 adresa
    • 2a01:490:1b:"58 00":"-- 64 bitová automaticky generovaná IP adresa --"/64 tj: konkrátně
    • 2a01:490:1b:3a00:20c:42ff:fe3d:f4c0/64
  • Příklad 2
    • IPV4 adresa routeru 10.93.63.205/30 tj. síť 10.93.63.204, dva poslední byty sítě "63 204" = hex(3fcc)
    • 2a01:490:1b:"63 204":"--64 bitová automaticky generovaná IP adresa --"/64 tj: konkrátně
    • 2a01:490:1b:3fcc:20c:42ff:fe1d:96f4/64

Co se musí udělat a co udělám

  • kdo chce, tak si to nastaví :-)

Problém

  • vyřešení přístupu pro IPV6 adresy, hotspot nefunguje, je založen na NAT, ten se u IPV6 nepoužívá, našel jsem nějaké řešení, musí se otestovat
  • nemá to prioritu, přes IPV6 se stejně nedá nikam dostat

Návod pro Mikrotik

  • Povolíme IPV6
    • /system package -> enable IPV6 reboot
  • Nastavíme IPV6 IP adresy tj. pro router na sítích např. 10.93.253.0/24 a 10.93.123.49/30
    • 2a01:490:1b:fd00::/64 aui-64=yes
    • 2a01:490:1b:7B30::/64 aui-64=yes
  • Nastavíme firewall přístup jen z rozsahu czela.net (routery jsou přístupné z celého internetu) !!!
/ipv6 firewall filter
add action=accept chain=input comment="Allow established connections" \
   connection-state=established disabled=no
add action=accept chain=input comment="Allow related connections" \
   connection-state=related disabled=no
add action=accept chain=input comment="Allow limited ICMP" disabled=no limit=\
   50/5s,5 protocol=icmpv6
add action=accept chain=input comment="Allow UDP" disabled=no protocol=udp
add action=accept chain=input comment=OSPF disabled=no protocol=ospf
add action=accept chain=input comment=BGP disabled=no dst-port=176 protocol=\
   tcp
add action=accept chain=input comment="Local prefix" disabled=no src-address=\
   2a01:490:1b::/48
add action=drop chain=input disabled=no
  • Nakonfigurujeme OSPFv3, to je jen pro IPV6, standardní OSPF necháme
    • /routing ospf-v3
    • instance zadáme router id (ip adresa) a redistribute-connected=as-type-1
    • interfaces na kterých bude běžet OSPFv3, stejné costy restransmit interval (240)jako o klasického OSPF
    • počkáme, až se chytne OSPFV6
  • takhle nakonfigurujeme všechny sítě až k nám
  • pingáme si na 2001:4860:4860::8888 (ipv6 dns google) abychom měli jistotu, že nám to funguje
  • na koncovém routeru přidáme 2001:4860:4860::8888 jako další DNS server
    • /ip dns -> přidáme 2001:4860:4860::8888 jako další DNS server
  • povolíme u neighbour detection DNS
    • /ipv6 nd -> advertise-dns=yes
  • na Ubuntu
    • nainstalujeme balíček rdnssd- sudo apt-get install rdnssd
    • připojíme kabel
    • (Ubuntu) ip addr show - kontrola jestli máme správnou IP adresu podle sítě
  • windows7
    • se chytly samy
  • Windows XP
    • Instalace IPv6 protokolu v příkazovém řádku:
    • pro jistotu zastavit službu (kdyby už tam byla) - net stop tcpip6
    • nainstalovat protokol - netsh interface ipv6 install
    • spustit službu - net start tcpip6
  • kontrola
    • (Ubuntu) ping6 2001:4860:4860::8888
    • (Ubuntu) ping6 ipv6.seznam.cz
    • (Windows 7) ping 2001:4860:4860::8888
    • (Windows 7) ping ipv6.seznam.cz
    • (Windows XP)

Jak se dostat do IPV6 ze sítě IPV4

  • teredo tunel Ubuntu
    • nainstalujete miredo sudo apt-get install miredo
    • do /etc/miredo/miredo.conf doplnit ServerAddress teredo.nic.cz
    • sudo service miredo start
    • ip -6 addr meli byste mít IPV6 adresu na teredo interface
    • ping6 2001:4860:4860::8888 (google) nebo váš router
  • Windows 7 ho mají standardně zapnutý

Sítě, kde je povoleno IPV6

Sítě IPV6
Síť Popis Kdy Kdo
10.93.253.0/24 páteř vlan 253 21.5.2012 V.Daňhelka
10.93.2.48/30 Alcoma Zadráha 21.5.2012 V.Daňhelka
10.93.63.240/28 Zadráha páteř 21.5.2012 V.Daňhelka
10.93.58.0/24 Lidická 21.5.2012 V.Daňhelka
10.93.251.0/24 Spoj do Ginu pater vlan 251 21.6.2012 V.Daňhelka
10.93.2.60/30 Spoj do BGP routeru GIN-RB1100Ah2 21.6.2012 V.Daňhelka
10.93.252.0/24 Spoj do Rumu pater vlan 252 23.8.2012 V.Daňhelka
10.93.2.64/30 Spoj do BGP routeru RUM-RB1100Ah2 23.8.2012 V.Daňhelka
10.93.93.192/30 Ruska mesto na Volfika 5GHz 23.8.2012 V.Daňhelka
10.93.93.204/30 Zalozni spoj pres pater Jirina-Ruska 23.8.2012 V.Daňhelka
Osobní nástroje
Jmenné prostory
Varianty
Akce
Navigace
Nástroje