VLAN

Z Czela.net
Přejít na: navigace, hledání

Obsah

Mapa VLANu

Vlany.png

aktualni, pripadne budouci stav ;)

Cislovaci plan

http://10.93.1.221/pub/obrazky/000_WEB/areas.png

Area Subnety Peery rezerva
Area 0 10-59 60-89 90-99
Area 1 100-159 160-189 190-199
Area 2 200-259 260-289 290-299
Area 3 300-359 360-389 390-399
Area 4 400-459 460-489 490-499


Kazdopadne je potreba zmenit vlan pro pater, ted bezi na primary vlan 1 a to neni spravne.

VLAN1 by mela mit vlastni subnet a v ni pouze switche a jejich managementy.

Zabory

VLAN Ucel ip range poznamka
1 default, management
2 peer Rumcajs - vodojem 10.93.162.0/28
5 backbone 10.93.1.192/26
8 CZF-peering
Konwes pojitka
10.253.32.0/24
10.93.3.0/24
10 subnet Stankovskeho 10.93.10.0/24
20 subnet Cina 10.93.20.0/24
47 subnet Uciliste 10.93.47.0/24
500 LAN Zapy 10.93.101.0/24
800 spoj kremilek-Zapy 10.93.5.0/24 zvolit rozsah
801 NCX Zapy 10.253.1.0/24 zmenit na volny rozsah z czely
4001 konektivita NFX 81.201.48.192/26

Jak na to

Co je to VLAN

VLAN je virtualni LAN, omoznuje v siti vytvaret vice virtualnich siti. Jednim kabelem pak vede vice virtualnich. Princip je jednoduchy, k ethernetovemu paketu se pripoji jeste znacka, ktera urcuje do ktere VLANy dany paket patri, tim se odlisi "po kterem kabelu" paket putuje.

Pri vstupu do switche se pakety vzdy oznackuji (otaguji), pri vystupu ze switche se but odznackuji a nebo ne, podle toho v jakem modu je dany port nastaven.

VLANy pouzivaji dva druhy portu:

Cisco

Access

To je koncovy port, vede do nej jen jedna VLAN. Pri prichodu paketu na tento port se paket oznackuje, pri odchodi se odznackuje.

enable
configure
interface GigabitEthernet 0/5
duplex full 
speed 100 
description "port ve VLAN1000"
switchport mode access
switchport mode switchport access vlan 1000

Trunk

Tento port pri odchodu pakety neodznackuje, takze umoznuje vedeni vice VLAN v jednom kabelu.

Tento typ portu se nastavuje, v pripade propojeni switchu - aby se vsechny VLANy prenesly i na druhy switch. Nebo pri zapojeni do routeru, ktery ma podporu VLAN.

enable
configure
interface GigabitEthernet 0/5
duplex full 
speed 100 
description "trunk port 1,1000"
switchport mode trunk
switchport trunk allowed vlan 1,1000

Standardne po trunku bezi vsechny VLANy, naopak pomoci *trunk allowed* se nechaji omezit.

Je mozny taky nastavit native vlan, to je VLAN, ktera bezi v trunku netagovana (jako by byl port v modu trunk ale zaroven v access pro danou vlan).

switchport trunk native vlan 1

V linuxu je to jednoduchy, je potreba mit podporu v jadre a nainstalovanou utilitku vconfig. Pak se VLAN prida:

vconfig add eth0 1000

nebo v /etc/interfaces se primo nastavi sitovka eth0.1000 uplne stejne jako kdyby byla standardni.

Nastaveni NTP serveru

conf t
ntp server 10.93.0.1 key 0 prefer
ntp server 195.113.144.201
clock timezone GMT +1

Zobrazeni stavu:

sh ntp status

Akualni cas:

sh clock

Spojovani portu

Nahozeni Port-channelu

conf t
interface Port-channel 1
no shutdown
end

conf t
interface Port-channel 2
no shutdown
end

Prirazeni dvojic portu do portchanelu 1

conf t
interface range Gi0/9-10
channel-group 1 mode on
end

Prirazeni dvojic portu do portchanelu 2

conf t
interface range Gi0/11-12
channel-group 2 mode on
end
Osobní nástroje
Jmenné prostory
Varianty
Akce
Navigace
Nástroje